Email delivery problems

Incident Report for OTOY

Resolved

This incident has been resolved.
Posted Aug 29, 2024 - 18:34 PDT

Update

The issue has been identified and resolved.
Posted Aug 29, 2024 - 18:34 PDT

Investigating

We are currently experiencing issues with email delivery and are investigating the cause.

Emails such as ORC and RNDR status updates, account information or password resets may not be sent at present.
Posted Aug 29, 2024 - 14:15 PDT
This incident affected: OTOY Account System, OctaneRender Cloud, and Websites.