Account system degraded performance

Incident Report for OTOY

Resolved

We have identified and corrected the problem.
Posted Oct 08, 2025 - 11:56 PDT

Investigating

Our alarms have detected an elevated level of errors in the account system (account.otoy.com), we are currently investigating the cause.
Posted Oct 08, 2025 - 11:08 PDT
This incident affected: OTOY Account System.