Subscription signup issues
Incident Report for OTOY
Resolved
We have detected no further cases related to this incident.
Posted 11 months ago. Jan 08, 2018 - 14:35 PST
Monitoring
The issue has been identified and resolved, and the subscription sign-up system is back online. We will continue to monitor the subscription service, so please email help@otoy.com if you are still experiencing any issues.
Posted 11 months ago. Jan 07, 2018 - 19:42 PST
Investigating
We are currently investigating a PayPal API issue that is preventing us from correctly processing new subscriptions. We sincerely apologize and are working with PayPal to resolve this as quickly as possible.
Posted 11 months ago. Jan 07, 2018 - 16:52 PST
This incident affected: Websites.