Elevated Email Sending Issues
Incident Report for OTOY
Resolved
We have resolved the issue impacting email delivery from the SSO system, and verified that the problem is resolved.
Posted over 2 years ago. Jun 19, 2016 - 23:54 PDT
Investigating
We're currently experiencing an issue with account verification and password recovery email transmission. We are currently investigating the cause and will post updates as we progress.
Posted over 2 years ago. Jun 19, 2016 - 16:58 PDT
This incident affected: OTOY Account System.