DNS issues with upstream providers
Incident Report for OTOY
Resolved
This incident has been resolved.
Posted about 2 years ago. Oct 21, 2016 - 15:19 PDT
Monitoring
We are aware of issues in DNS resolution for our account and other services, we are monitoring the outage and working with our partners to mitigate.

Additional status updates are available at https://www.dynstatus.com/incidents/nlr4yrr162t8
Posted about 2 years ago. Oct 21, 2016 - 12:20 PDT
This incident affected: OctaneLive, OTOY Account System, and Websites.